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1. The EVAN Toolbox (ET) 

The EVAN Toolbox (ET) is a software package developed by the European Virtual Anthropology Network - EVAN 
(www.evan.at) and the EVAN-Society to facilitate form and shape analysis of objects featuring a complex 
geometry. It uses Geometric Morphometrics (GM) which includes methods such as General Procrustes 
Analysis, Principal Component Analysis, Thin-Plate Spline Warping or Partial Least Squares Analysis. These 
features are all embedded in the ET Core.  

In addition, the EVAN Toolbox supports data acquisition, i.e. to locate landmarks and semilandmarks on 
surfaces and curves. This part is realized in ET Templand, a node that can be started from the ET user interface. 
This manual describes how to use this Templand node.  

 

2. Landmarks and semilandmarks 

ET Templand is a tool that allows landmarking and semilandmarking of specimens. While landmarks (LM) 

characterize biologically homologous points on a specimen (such as the crossing of the sagittal and coronal 

sutures or the most extreme point on the mastoid process), sliding semilandmarks (sLM) are placed along 

curves (e.g, on ridges like the orbital rim) or on surfaces (e.g., on the parietal bone where not much real 

landmarks are) (see the six types of landmarks in Weber & Bookstein, Springer Verlag, 2011). Sliding 

semilandmarks are considered to be geometrically homologous (Gunz & Mitteroecker 2013; Gunz et al. 2005). 

The placing of semilandmarks requires a sample. Semilandmarks are based on the Thin Plate Spline (TPS) 

function (Bookstein 1991) and allowed to slide in relation to the landmark configurations in the sample. This 

sliding involves different degrees of freedom: 

 

a) Semilandmarks on curves have 1 degree of freedom to slide  

(along the defined curve) 

b) Semilandmarks on surfaces have 2 degrees of freedom to slide  

(on the defined surface) 

c) Points that are declared "missing" have 3 degrees of freedom to slide  

(within the whole data volume) 

 

The ET Templand node offers procedures to identify classic landmarks and also semilandmarks mentioned 

under point a) and b) above. To start the process, a template is defined. At start this will be any specimen, 

preferably a specimen near the mean shape. All LM and sLM are identified on this specimen. Then, we have to 

identify LM on a second specimen, the first target specimen. The sLM from the template will be projected to 

the target and then slid. This process is iterative until no differences are appreciable (usually, a few rounds of 

project-slide will do). The next specimen, the second target, will undergo the same procedure, and so on. Once 

all specimens in the sample have been done, the coordinates of LM and sLM are used for a "Procrustes 

Superimposition" (which you know from the standard features of ET Core) and the template can be replaced 

by the resulting average configuration (consensus button). All specimens are then slid against this average 

again. These final results can be used for further analyses of form and shape. For that, you use the ET Core 

where all the nodes for Procrustes Superimposition, Principal Component Analysis or Partial Least Squares 

analysis are available.   

 

3. The example data 

We will use an example from dental anthropology to demonstrate the principle workflow and the individual 

working steps in this manual. Our example data involves the dentin bodies of human upper molars. The 

surfaces have been extracted from µCT images by segmenting the enamel and the dentin (which can be done 

e.g. in Amira, Avizo, TurtleSeg, ImageJ or similar software packages), creating triangulated surfaces for the  
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dentin, and saving these surfaces in .obj format (ET Templand will only use OBJ format for surfaces, ET Core 

can also handle other formats such as STL). For your orientation, we provide an annotated picture here 

showing the enamel surface (left - yellow) and the dentin surface (right -grey) of a human upper left second 

molar (M2) from occlusal view. M – mesial, D – distal, B – buccal, L – lingual.  

 

The cusps and ridges on the dentin surface are easily identifiable. There are 10 classic landmarks (yellow 

spheres in the figure below) which we will use in our data set. Each of them comes with a specific name and a 

clear definition where they are located. Choosing these landmarks on the surface of the dentin crown, we took 

care that they were well distributed across the whole structure because they establish a framework for sliding 

semilandmarks later.  

  

Classic Landmarks 

No. Landmark Location 

1 Cervix_Bucc  the midpoint of the cervical margin buccally 

2 Cervix_Dist  the midpoint of the cervical margin distally 

3 Cervix_Ling  the midpoint of the cervical margin lingually  

4 Cervix_Mesi  the midpoint of the cervical margin mesially  

5 Hypocone  the tip of the hypocone  

6 Metacone  the tip of the metacone  

7 Paracone  the tip of the paracone  

8 Protocone  the tip of the protocone  

9 Talon_Bott  the deepest point in the talon  

10 Trigon_Bott  the deepest point in the trigon  

 

The dentin crown also features some nicely expressed ridges which are ideal for curve semilandmarks 

(comparable to muscle markings on long bones or the temporal line on the cranium, if working with bones).  

 

One of these ridges runs between the Protocone, the Paracone, and the Metacone. We call it “Curve_Trigon” 

in our example and it consists of 15 curve semilandmarks (blue spheres in the figure below).  
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The other curve can be traced by 5 curve semilandmarks from the Metacone to the Hypocone and is called 

“Curve_Talon” (green spheres in the figure below).  

 

Finally, we include 8 surface semilandmarks (red spheres in the figure below) within the trigon around the 

deepest point to capture the geometry of this depression and call it “Surface_Trigon”.  

 

Curve semilandmarks have to be affiliated to a predefined curve which needs to be digitised in advance by 

following an actual ridge on the surface. Surface semilandmarks have to be affiliated to a surface which is in 

this case the entire surface of the dentin crown (but you could theoretically divide the surface into several 

patches and assign different blocks of surface semilandmarks to these different patches).  

 

 

Curve_Trigon Semilandmarks 

No. Semilandmark Location 

1 SM00001 start near the Metacone 

2 SM00002 continue in the direction of the Protocone 

3 SM00003 continue in the direction of the Protocone 

4 SM00004 continue in the direction of the Protocone 

5 SM00005 almost reached the Protocone 

6 SM00006 start near the Protocone (on its other side) 

7 SM00007 continue in the direction of the Paracone 

8 SM00008 continue in the direction of the Paracone 

9 SM00009 continue in the direction of the Paracone 

10 SM00010 almost reached the Paracone 

11 SM00011 start near the Paracone (on its other side) 

12 SM00012 continue in the direction of the Metacone 

13 SM00013 continue in the direction of the Metacone 

14 SM00014 continue in the direction of the Metacone 

15 SM00015 almost reached the Metacone 

Curve_Talon Semilandmarks 

No. Semilandmark Location 

1 SM00001 start near the Metacone 

2 SM00002 continue in the direction of the Hypocone 

3 SM00003 continue in the direction of the Hypocone 

4 SM00004 continue in the direction of the Hypocone 

5 SM00005 almost reached the Hypocone 

Surface_Trigon Semilandmarks 

No. Semilandmark Location 

1 SM00001 start near the Metacone 

2 SM00002 continue counterclockwise 

3 SM00003 continue counterclockwise 

4 SM00004 continue counterclockwise 

5 SM00005 continue counterclockwise 

6 SM00006 continue counterclockwise 

7 SM00007 continue counterclockwise 

8 SM00008 continue counterclockwise 
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Please note: For any study using landmarks, it is absolutely crucial to make sure that the order of digitized 

landmarks is the same for each specimen.  

 

 
 

 

4. File Types 
Templand creates two types of files, one is a form file, and the other is a tableau file (see figure below). 

Surfaces and curves are always coming as OBJ files.  

 

 Surface and curve files (.obj) contain the 3D surface of an object or a 3D curve which have been 

created in other software or in ET in .obj format (v-vertices, e-edges, f-faces). They can be edited in 

Wordpad if the format is distorted. 

 

 Form files (.frm) contain one individual specimen. This will include the surface files (.obj), predefined 

curves (.obj), identified LMs and sLMs on surfaces and curves, and other information (e.g. about 

symmetry) related to the landmarking operation. Each form file can be thought of as storing either the 

full set of landmarks or an intermediate stage during the landmarking process.   

 

 Tableau files (.ltb) contain information on the sample. They connect sequences of form files allowing 

the computation of a consensus or the export of all landmark configurations at once, or an animation 

or video of the landmarking sequence to be produced and displayed. Form files can be “appended". 

 

                     Form file (.frm)                      Append               Tableau file (.ltb) 
           
 
 
 

Surface (.obj) 

Curves (.obj) 

Landmarks (LM) 

Semilandmarks (sLM) 

 

Template (.frm) 

Target 1 (.frm) 

Target 2 (.frm) 

… 

Target n (.frm) 
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5. The principle workflow 

ET Templand provides the freedom of digitizing classic landmarks and preparing curves in any software and 

then import them into a form-file. However, Templand offers these functions as well. In our suggested 

workflow here we assume that all steps are carried out in Templand. 

 

Once you have the surface files of all objects in the sample ready in .obj format, you can start digitizing classic 

landmarks. If you will have curve semilandmarks as well, it is however better to start building those curves first. 

For our example data, the workflow looks as follows: 

 

 Preparation of the sample 

o Create surface files for each specimen as .obj in an appropriate software package  

o Create curves for each specimen and save them as .obj 

o Locate classic landmarks on each specimen, import curves, and save each specimen as .frm 

o Decide which specimen will be used as template (in the example data this is tooth “152”) 

o Locate semilandmarks on the template specimen and save the .frm 

 Creating sliding semilandmarks 

o Load the template form 

o Save a tableau file as .ltb 

o Append the template form as the first specimen 

o Change view to 4-window view (“Template”) 

o Load the template form in the upper window 

o Reset the lower window and load the first target form (tooth “697”) 

o Warp all unmatched landmarks from the template to the target 

o Append the first target to the tableau file 

o Reset the lower window and load the second target form (tooth “S4”) 

o Warp all unmatched landmarks from the template to the target 

o Append the second target to the tableau file 

o ... continue for the whole sample (if larger) … 

o Save the tableau file 

o Create consensus and warp all specimens against consensus (“152” will then be a normal 

target specimen) 

 Analyzing the data 

o Export landmarks for all specimens or import the tableau file in ET Core 

o Perform analyses of your sample in ET Core 

 

 

6. Starting Templand 

ET Templand is one of the available nodes in ET Core. To access Templand: 

1. Start the EVAN toolbox 

2. Go to the file menu 

3. Select "New" to begin a new untitled network.  

4. Click on the Templand node (tab “Data” of the left hand menu) just once with left mouse button 

5. Then click on the work space just once with left mouse buttion 

6. Double click on the Templand node (that appears now centre screen) 

7. In the new window (Templand GUI) that appears click again "File" > "New" 
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7. ET Templand Graphical User Interface (GUI) 
 

 

2. Go to the file menu 

3. Select “New” 

4. Click on Templand node 

(once left mouse button) 

5. Click on workspace  

(once left mouse button) 

6. Double click on 

Templand node 

7. In the new window click 

again "File" > "New" 

1. Start ET Core 
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The Templand GUI is the window within which you can identify landmarks and semilandmarks. Its left side will 

show the specimen in 3D, its right side will show a particular 2D slice through the specimen. It can beneficial 

for many applications to minimize the right window. The Templand window has a number of menued items at 

the top. 

File Menu 

The file menu allows you to: 

 create a “New” tableau, 

 “Open File” an existing tableau file, 

 “Save” and “Save as” tableau files, 

 and to “Refresh Output Ports”. It is important to note this item because it updates the data for the 

export, i.e. the LM and sLM coordinates that you have gathered in Templand and that you now want 

to submit to the ET Core for further analysis. 

 

View Menu 

The view menu contain two items 

 “Template”: toggles between the view for one specimen (as you have seen above) and a view for two 

specimens. The one on top must be the template specimen which is required to transfer landmarks to 

the target (which you must load in the bottom windows). 

 “Background”: lets you change the background colour. 

 

Window Menu 

The window menu allows to arrange views conveniently, as known from other Windows applications. 

 

The Item Menu  

To the right of the two windows showing the specimen is the Item Menu. When data have been imported, this 

contains information about the specimen in terms of the surface, the curves, the landmarks and the 

semilandmarks. All together is called a “form” and can be saved as a form file (*.frm).  

 

The interface also allows the user to control whether or not the slice through the object is visible in either the 

left hand window (the view window) or the right hand window (the slice window). Surfaces, curves and 

landmarks can also be turned off and on by ticking the appropriate check boxes.  

 

8. Loading a Surface or a Curve 

The first step in building a form is to load a surface. To do this: 

1. Right click on “Surfaces” in the Item Menu and select "Import Surface" 

2. Select the surface that you wish to import from your directory (the only surface format supported is 

.obj) and choose “Open”. Then provide an “Item ID”. This name will be used in the Item Menu and has 

to be consistently used for all surfaces in your sample (for our example data, we use 

“Surface_Dentin” as Item ID). The 3D surface will appear in the left hand window (View) and a section 

through this surface will appear in the right (Slice).   

3. In the same way you can load a curve (the only curve format supported is .obj). The curve has to be a 

polyline and may be created in Templand or in another software. Right click on “Curves”, select 

“Import Curve”, and select the curve object to load. Again provide an “Item ID”. Each name will be 

used in the Item Menu and has to be consistently used in your sample for a particular type of curve 

(for our example data, we use “Curve_Talon” and “Curve_Trigon” as Item IDs). The curve(s) will show 

up in the left and right hand windows as a red line.  
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Activating the “View” for “Slice” in the Item Menu will show the actual slice position for the right hand window 

in the 3D rendering of the left hand window as a blue plane. In both windows the view can be modified 

following the instructions below: 

 

Templand User Controls 
 
Mouse 
Left mouse button drag    Tumble  
Left mouse button drag + Alt  Rotate  
Left mouse double click      Create a Landmark  
Right mouse button drag    Zoom  
Right mouse button    Selects a Landmark 
Middle mouse button drag   Translate 
Middle mouse button scroll   Clipping 
 

Keys 
Arrow Keys    90 degree rotations 
r R      120 degree rotation 
[ ]      90 degree twists 
+ -      Jump Zoom 
Page Up/Down     Jump Clipping 
M      Move selected Landmark 
C      Center View 
Spacebar    Focus at View 
 

Pressing and holding Ctrl along with keys/mouse navigation buttons will result in fine 

control of the movement. 

 

Note: the direction and keyboard keys only work when surface or slice is highlighted in the items menu; it 

will not work if landmarks are highlighted. Use the jump push function when zooming in on a position the 

Surface_Dentin 

Curve_Talon 

Curve_Trigon 
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camera view cuts through the surface you wish to magnify. In the Templand GUI top right underneath the 

menu labels there are a series of arrows   which can be selected. These constrain the way in which the slice 

moves under mouse control.   

 
 

9. Placing a landmark 

To place a landmark, position the cursor over the relevant position in either the view (left) or the slice (right) 

window and double click. Check the point from different viewing angles if it is correct, it might look different 

from different views. A red cross will appear at the location of the landmark and in the Item Menu, the 

landmark will be named starting with LM00001, LM00002, …, LM99999. If you want to give it a proper name 

(which can make sense, e.g. for classic landmarks), then right click on the landmark’s current name and choose 

“Rename” and type a new name. Left of the name appears [F] which indicates that the position of this 

landmark is “fixed” which would be the correct status for a classic landmark located by the user. It was not 

“warped” [W] from another specimen, and it was not “projected” [P] or “slid” [S]. You will see these attributes 

later in the context of semilandmarks. 

 

If there is more than one landmark, you can select each landmark in the Item Menu. A currently selected 

landmark or the most recently placed landmark is displayed in red, the remaining landmarks in green. The size, 

colour and symbol used to display the landmarks can be changed by right clicking on “Landmarks” in the Item 

Menu at right and selecting “Colour”, “Size” (stepwise increase or decrease) or “Symbol” (cross, square, dot). 

 

If you want to delete a landmark, right click on it in the Item Menu and select “Delete”. You should do this only 

for the last landmark you located because you will otherwise mess up the order and naming of your 

landmarks! In case you are not satisfied with the position of a landmark that isn’t last, right click on it in the 

Item Menu and select instead “Move”. Drag your mouse to the new position and double click. The landmark 

will be moved there. 

 

10. Adding semilandmarks 

If you wish to work with semilandmarks in addition to classic landmarks, for one specimen in your sample – the 

template – you have to locate those semilandmarks manually. They can be on curves and on surfaces and will 

be arranged in groups. In order to add semilandmarks, right click on the “Landmarks” heading within the Item 

Menu and select "Add Semilandmark". You must now provide an “Item ID” for the first group of 

semilandmarks. This name will be used in the Item Menu and has to be consistently used in your sample for a 

particular type of semilandmarks (for our example data, e.g. we use “sLM_Curve_Talon”, “sLM_Curve_Trigon”, 

and “sLM_Surface_Trigon” as Item IDs). Most importantly, by choosing from a list, embed (affiliate) your 

semilandmark group with a particular item which has to be an object already loaded in your form file. In our 

example data 

 

“sLM_Curve_Talon”  are embedded in   “Curve_Talon” 

“sLM_Curve_Trigon”  are embedded in  “Curve_Trigon” 

“sLM_Surface_Trigon”  are embedded in  “Surface_Dentin”.  

 

Click on a semilandmark group in the Item Menu to highlight it. Now you can start placing semilandmarks along 

a curve or on a surface the same way you located landmarks. The automated numbering will start with 

SM00001, SM00002, …, SM99999. You can rename semilandmarks though this doesn’t make much sense since 
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semilandmarks are treated as a group. Once all semilandmarks for one semilandmark group have been defined, 

you can create another group. In our example we will use two curves and one surface with sLM. 

 

11. Save and export a form file 

At any stage during landmarking you can save the form file, which will contain the coordinates of each 

individual landmark and semilandmark, the pointer to the objects used (surfaces, curves), and the embedding 

information. Right click on “Form” (top line in the Item Menu) and select “Save” or “Save as”.  

 

The coordinates of landmarks and semilandmarks can be exported at any time as simple text file which is easy 

to read with any software, and of course also ET Core. Right click on “Landmarks” (Item Menu) and select 

“Export Landmarks for this Specimen”. The text file will have no labels, just X-, Y-, and Z-coordinates per 

landmark and semilandmark, but the order of LM and sLM will be exactly that one of the Item Menu.  

 

12. Creating a tableau file 

A tableau is a sequence of form files. It can be used to export data of the sample or even to show the 

landmarking process. It can be created at any point in time. However, it is advisable to save a tableau at the 

beginning of a process, e.g. before sliding all targets against the template (see chapter “5. The principal 

workflow” above). To create a tableau file select from the top menu bar “File” and “Save as” to save the new 

tableau file (.ltb). In the case multiple forms have been appended to the tableau file, their coordinates can be 

exported in one process. Right click on “Landmarks” (Item Menu) and select “Export Landmarks for all 

Specimens” to export X- Y-, and Z-coordinates of all landmarks and semilandmarks for all specimens included 

in the tableau file.  

 

ET Core can also read tableau files directly, thus an export is only necessary if you intend to use the coordinate 

data in another software. To import a tableau file, create an “Import” node in ET Core, double click it and select 

“Tableau” as “Datafile format”. This will import all coordinate data of all specimens but not any surface file. As 

usual (see “Manuals  for the EVAN Toolbox No. 2”), the surface of one particular specimen has to be loaded 

separately. ET Core will also accept .stl (beside .obj) for visualization. 

 

The tableau file can be replayed as it is being built (or reloaded from a saved tableau file) by using the controls 

at the bottom left of the Templand window. These controls   are similar to the 

controls you would find them on an MP3-player and have similar action. The tableau allows also to record the 

process of landmarking: 

 

1. Load a surface and curves 

2. Prior to adding any landmarks select “File” and “Save as” to save the new tableau file (.ltb) 

3. Add one landmark as described above 

4. Right click on “Form” in the Item Menu and select “Append” 

5. Add a second landmark 

6. Right click on “Form” in the Item Menu and select “Append” 

7. Following each subsequent landmark added select “Append” before adding the next landmark 

8. After the landmark sequence is complete “Save” the tableau file in its current stage 

 

Note: each individual landmark will be saved as a .frm file, and there will also be a tableau file save in the .ltb 

format. It is the tableau (.ltb) file that needs to be opened in order to replay the landmark sequence.  
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13. Working with the example data 
 

As outlined above, the surface files for the dentin crowns of three human upper second molars have to be 

created in other software. Our sample includes “152_uLM2_Dentin.obj” which will be the template, 

“697_uLM2_Dentin.obj” as target no. 1, and “S4_uLM2_Dentin.obj” as target no. 2.  

In the following instructions, input files will be printed in blue, output files in green. 

As next step we describe how to create a curve in ET Templand. 

 

Creating curves in Templand  
Open Templand 
Right click “Surfaces” from the Item Menu 
Select “Import Surface” and select 
“152_uLM2_Dentin.obj” as file > for “Item ID” specify 
"Surface_Dentin" 
 
Locate landmarks for the curve as described above 
under “Landmarking”. The curve in ET will be a polyline 
which is connecting points with straight lines (it is not 
interpolating a spline). The more points you define, the 
better the representation will be (see image to the 
right). In our example, place approximately 70 LM on the 
trigon ridge, start at the Metacone, move clockwise, and 
always stay on the ridge.  
 
Right click “Landmarks” > “Save as Curve” > name it "152_Curve_Trigon.obj" 
Once the curve is saved, you do not need these 70 landmarks anymore. 
Delete all the landmarks that were defining the polyline by right clicking “Landmarks” > “Delete all Landmarks” 
 
Create in the same way another curve for the talon which you call “152_Curve_Talon.obj”.  
Create the curves for the other specimens in the sample. You may also create curves in other software and 
later import as OBJ files. 
 
Locate classic landmarks on the template 
Now that we obtained polylines for curves, the actual process of landmarking starts. 
We have to define classic landmarks prior to the placing of semilandmarks on curves and surfaces. This step is 
obligatory, since LMs are required to make the TPS warping of semilandmarks possible.  
 
Open Templand 
Right click “Surfaces” from the Item Menu 
Select “Import Surface” and select “152_uLM2_Dentin.obj” as file > as “Item ID” specify "Surface_Dentin" 
Click on "Landmarks" in the Item Menu 
Locate the 10 classic landmarks on the object as outlined in “3. The example data” and rename them 
accordingly.   
Right click “Form” > “Save as” > name it "152dentin_trueLM.frm" 
Study the structure of the .frm file in Wordpad, you might need to interact with it directly in case of problems. 
 
Import curves for the template 
We can now import the predefined curves to prepare our form file for the adding of semilandmarks. 
 
Right click “Curves” > “Import Curve” > select "152_Curve_Talon.obj" > as “Item ID” specify "Curve_Talon" 
The curve will appear on the surface as a red line. You can change colour by right-clicking “Curve_Talon” > 
“Colour”. 
Right click “Curves” > “Import Curve” > select "152_Curve_Trigon.obj" > as “Item ID” specify "Curve_Trigon" 
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Right click “Form” > “Save as” > name it "152dentin_trueLM&2curves.frm" 
 
Add semilandmarks to the template 
As described above in point “10. Adding semilandmarks” we have to locate them once on the template 
specimen. Our goal here is to include semilandmarks on two curves and on the trigon surface. 
 
Right click “Landmarks” > “Add semilandmarks” > as “Item ID” specify "sLM_Curve_Talon" > Embed with item > 
"Curve_Talon" 
Select "sLM_Curve_Talon" in the Item Menu 
Place semilandmarks along the polyline of the talon as outlined in “3. The example data” (green) 
If you are not exactly on the polyline when you place them, the semilandmarks will be automatically projected 
to the nearest point of the polyline (you will recognize the [P] in front of the semilandmark group). If you are not 
satisfied with the location of a semilandmark, select it from the Item Menu, hold “Ctrl+M” keys, and move your 
mouse over a different location. Click the left mouse button once to place it there. 
 
Right click “Landmarks” > “Add semilandmarks” > as “Item ID” specify "sLM_Curve_Trigon" > Embed with item 
> "Curve_Trigon" 
Select "sLM_Curve_Trigon" in the Item Menu 
Place semilandmarks along the polyline of the trigon as outlined in “3. The example data” (blue) 
 
Right click “Landmarks” > “Add semilandmarks” > as “Item ID” specify "sLM_Surface_Trigon" > Embed with 
item > "Surface_Dentin" 
Select "sLM_Surface_Trigon" in the Item Menu 
Place semilandmarks in the basin of the trigon as outlined in “3. The example data” (red) 
When double-clicking the left mouse button, the surface semilandmarks will be automatically projected to the 
nearest point of the surface. In this case they keep the attribute [P] because they will be projected and slid later 
for all target specimens. If you are not satisfied with the location of a placed semilandmark, select it from the 
Item Menu, hold “Ctrl+M” keys, and move your mouse over that semilandmark. It will follow now your mouse 
pointer. Click the left mouse button once to place it in a different location.  
 
Right click “Form” > “Save as” > name it "152dentin_trueLM&2curves&surface_sLM.frm" 
 
 

 
 
Preparing the target specimens 
The target specimens “697” and “S4” are other two upper second molars that will be treated in a similar way 
than the template “152”. The difference is, however, that only the classic landmarks have to be defined and 
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the predefined curves have to be imported into the form files. The semilandmarks will then be warped 
automatically from the template specimen.  
 
Open Templand 
 
Right click “Surfaces” from the Item Menu 
Select “Import Surface” and select “697_uLM2_Dentin.obj” as file > as “Item ID” specify "Surface_Dentin" 
Click on "Landmarks" in the Item Menu 
Locate the 10 classic landmarks on the object as outlined in “3. The example data” and rename them 
accordingly.   
Right click “Form” > “Save as” > name it "697dentin_trueLM.frm" 
Right click “Curves” > “Import Curve” > select "697_Curve_Talon.obj" > as “Item ID” specify "Curve_Talon" 
Right click “Curves” > “Import Curve” > select "697_Curve_Trigon.obj" > as “Item ID” specify "Curve_Trigon" 
Right click “Form” > “Save as” > name it "697dentin_trueLM&2curves.frm" 
 
Right click “Form” > “Reset” 
 
Right click “Surfaces” from the Item Menu 
Select “Import Surface” and select “S4_uLM2_Dentin.obj” as file > as “Item ID” specify "Surface_Dentin" 
Click on "Landmarks" in the Item Menu 
Locate the 10 classic landmarks on the object as outlined in “3. The example data” and rename them 
accordingly.   
Right click “Form” > “Save as” > name it "S4dentin_trueLM.frm" 
Right click “Curves” > “Import Curve” > select "S4_Curve_Talon.obj" > as “Item ID” specify "Curve_Talon" 
Right click “Curves” > “Import Curve” > select "S4_Curve_Trigon.obj" > as “Item ID” specify "Curve_Trigon" 
Right click “Form” > “Save as” > name it "S4dentin_trueLM&2curves.frm" 
 
 
Create a Tableau file and sliding semilandmarks of the target specimens 
All the form files for the three specimens in our sample are now ready for the last and crucial step, the warping 
of the semilandmarks from the template to the targets and subsequent iterative slide-project step. We just use 
three specimens here for simplicity but the process will also work with hundreds of specimens. 
 
Open Templand 
Click "File" > "New" 
Right click “Form” > “Load” > select file "152dentin_trueLM&2curves&surface_sLM.frm" 
Click “File” > “Save as” > name it “uLM2.ltb” to save a new tableau file  
Right click “Form” > “Append” to append the template as the first 
specimens to the tableau (the counter at the left bottom of the 
window changed to “1”). 
Click “View” > “Template” to change to the 4-window view 
In the upper row, right click “Form” > “Load” > select file 
"152dentin_trueLM&2curves&surface_sLM.frm" 
In the lower row, right click “Form” > “Reset” 
In the lower row, right click “Form” > “Load” > select file 
"697dentin_trueLM&2curves.frm" 
In the upper row (template), right-click “Landmarks” > “Warp all 
unmatched landmarks” 
 
A dialogue window like shown right here will appear that allows 
you to specify the parameters for the slide-project step. Activating 
the checkbox for “Slide Semi-Landmarks” enables the process. The 
options are to “Slide-Project Once”, or to specify the number of 
iterations under “Slide-Project # iterations”, or to define a certain  
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difference from one iteration to the next using “Slide-Project until error”.  
 
Enable sliding by checking the box on top “Slide Semi-Landmarks” 
Choose one of the options, e.g. Slide-Project # iterations = 7 
Click “OK” 
 
The unmatched semilandmarks, i.e. “sLM_Curve_Talon”, “sLM_Curve_Trigon”, and “sLM_Surface_Trigon” are 
now warped to the target specimen and then slid and projected 7 times. Depending on the speed of the 
processor and the number of landmarks this may take several seconds to minutes. The result appears in the 
lower window. The target specimen now has all semilandmarks in the Item Menu and they are shown on the 
surface of the specimen in the View window.  
 

 
 
In the lower row, right click “Form” > “Append” to append the target no. 1 as the second specimen in the 
tableau. The counter bottom left now shows “2”. 
Click “File” > “Save” to save the tableau in its current state 
In the lower row, right click “Form” > “Reset” 
In the lower row, right click “Form” > “Load” > select file "S4dentin_trueLM&2curves.frm" 
In the upper row, right click “Landmarks” > “Warp all unmatched landmarks” 
Enable sliding by checking the box on top 
Choose one of the options, e.g. Slide-Project # iterations = 7 
Click “OK” 
In the lower row, right click “Form” > “Append” to append the target no. 2 as the third specimen in the tableau 
Click “File” > “Save” to save the tableau in its current state 
 
Slide All function 
Make a copy of your directory since form files will be overwritten during the next steps. In case of problems 
you can go back to a former state. 
 
Click “Slide All” 
Choose one of the options, e.g. Slide-Project # iterations = 7 
Click “OK” 
MESSAGE “Compute spline before warping Template to Specimen” appears 
Click “OK” 
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The Target specimens are now slid and projected again. All the form files are now overwritten.  
Click “File” > “Save” to save the tableau in its current state 
 
Consensus function 
Make a copy of your directory since form files will be overwritten during the next steps. In case of problems 
you can go back to a former state. 
 
Click “Consensus” 
A dialogue box informs you that a GPA will be performed and the current template be replaced by the GPA 
mean shape (consensus). 
Click “OK”  
Tune the GPA settings if necessary (for standard cases you can leave them as they are) 
Click “OK” 
Choose one of the options, e.g. Slide-Project # iterations = 7 
Click “OK” 
Confirm “Done” 
 
A consensus was computed, the former template "152dentin_trueLM&2curves&surface_sLM.frm" was 
replaced by this consensus and renamed  "152dentin_trueLM&2curves&surface_sLM_consensus.frm". The OBJ 
surface is still from tooth No. 152 but it was warped towards the consensus configuration. That means the LMs 
and sLMs of this tooth are now at the position of the consensus, and not of the real tooth No. 152. The latter is 
now part of the sample and not anymore a template. The tableau now comprises 4 teeth.  
 
 
Export the Landmark configurations for analyses 
There are several ways of getting data from ET Templand out to ET Core or to other programmes.  
 
1. Data from the tableau file can be imported directly in ET Core at any point in time.  
If you are not yet familiar with ET Core, please consider the instructions in  
“Manuals  for the EVAN Toolbox No. 2”for the use of “Import” and “GPA”. 
 
Use a predefined “GPA.vpn” 
Double click the “Import” node and select “Tableau” as “Datafile format” > select file “uLM2.ltb” 

Run the network  
 
Open the “3DViewer” to get a visualization of the three upper second molars after a Generalized Procrustes 
Analysis (see below). You can also import one of the surfaces that were used for this example. From here, you 
can proceed with all kinds of shape and form analyses in ET Core. 
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2. Another simple way to store the created coordinate data is in a text-file: 
 
In the lower row, right click on "Landmarks” > Export Landmarks for all Specimens” > name it “uLM2.txt” 
 
'D:\path\152dentin_trueLM&2curves&surface_sLM.frm 

4.27058 11.0306 3.92942 

9.56317 10.3978 10.6095 

12.4628 6.34926 10.8249 

8.80493 6.28765 3.49794 

7.92563 6.13324 12.3458 

….. 

 
This file can be read with any editor and be easily imported by other spreadsheet or statistic applications. The 
order of landmarks corresponds exactly with the order in the Item Menu of Templand. 
 
 
 
 
 
3. Coordinates can be taken over by ET Core and be exported there in different formats, e.g. Excel or 
Morphologika 
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Click “File” > “Refresh Output Ports”  
(this can take a while, depending on the number of LM and 
performance of the computer) 
Switch back to ET Core window 
Place an "Export" node on the workspace 
Connect "All Specimens" of the "Templand" node with 
"Specimens" of the "Export" node  

Run the network  
Double click "Export" node > Specimens "Morphologika" 
format > "Export Specimens" > provide file name 
"uLM2_morphologika.txt" > OK 

Pause the network  
 
When you open the textfile, you can read and edit the data file in Morphologika format: 
 
[individuals] 

3 

[landmarks] 

38 

[dimensions] 

3 

[names] 

1 

2 

3 

[rawpoints] 

' 1 

4.27058141475 -3.92942137468 11.030601127 

9.56316928506 -10.6095383808 10.3978187865 

12.4628461435 -10.8248545249 6.34925518826 

8.80493200822 -3.49794476756 6.28765330736 

7.92562694985 -12.3458311982 6.13323854725 

… 
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